利用phpize追加php模块
本文最后更新于 2450 天前,其中的信息可能已经有所发展或是发生改变。

第一次安装php的时候,可能没有考虑周全,有些模块没有安装,需要安装某个模块的时候又不想重新编译php,那么就要用到一个自带的程序 phpize

在php的安装路径/bin/下面

现在我需要安装一个openssl模块,因为 composer 依赖于它。

首先,复制php源文件目录下的/ext/openssl目录到安装php的include/php/ext/目录下

比如这样:(相关路径改成你所对应的路径)

1、cp -r /usr/local/src/php-7.0.2/ext/openssl/ /usr/local/php/include/php/ext/

2、cd /usr/local/php/include/php/ext/

3、cp config0.m4 config.m4

4、phpize

5、./configure --with-openssl --with-php-config=/usr/local/php/bin/php-config

6、编辑php.ini文件,加入 extension = openssl.so

7、重启php     service php-fpm restart

8、查看      php -i|grep openssl

 

暂无评论

发送评论 编辑评论


|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇